Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2026 - 21:00 UTC
Scheduled
One of our upstream network providers will be carrying out planned maintenance in the Athens region during the window above.
Because our network is multihomed, we will gracefully reroute traffic away from the affected provider before the maintenance begins. Your services will continue to be served over our remaining upstream connections throughout the window.
No downtime or impact is expected, and no action is required on your part.
Our team will be monitoring throughout and will restore normal routing once the provider confirms their work is complete. If you have any questions, our support team is available as always.
Posted Jun 05, 2026 - 12:04 UTC
This scheduled maintenance affected: cPanel Hosting - ATH1.